I was glad to read in Matt's blog entry Solaris fibre channel management that Solaris 10u1 base OS now includes a fcinfo command to view HBA and connectivity information. BTW, Matt's blog is pretty cool for all things Solaris.
From Solaris 10 - man pages section 1M: System Administration Commands 816-5166 document,
fcinfo Â Fibre Channel HBA Port Command Line Interface
fcinfo hba-port [-l] [HBA_port_WWNÂ ]
fcinfo remote-port [-ls] [-p HBA_port_WWN] [REMOTE_port_WWNÂ ]
fcinfo is a command line interface that collects administrative information on fibre channel host bus adapter (HBA) ports on a host. It also collects data on any fibre channel targets that may be connected to those ports in a Storage Area Network (SAN).
The following subcommands are supported:
Lists information for the HBA port referenced by the specified HBA_port_WWN. If HBA_port_WWN is not specified, all fibre channel HBA ports on the host will be listed.
Lists the remote-port information for those remote ports that are specified. If no REMOTE_port_WWN is specified, all remote ports that are visible through HBA_port_WWN are listed.
SUN is not generally considered to be at the forefront of storage innovation. And sure enough, Microsoft also has fcinfo utility (Download) for Windows Server 2003 and Windows 2000 systems. The cool feature is that you don't need to install it on the host.
Microsoft also mentions that fcinfo utility is based on the SNIA HBA API for management of Fibre Channel Host Bust Adapters and discovery of SAN resources. There is also an open source project The Fibre Channel HBA API Project on Sourceforge with more information.
SNIA is good for something finally!